pgAdmin 3 ou pgAdmin 4 ?

Que l'outil soit basique ou avancé, pour pouvoir travailler avec PostgreSQL, il faut déjà se connecter !
Répondre
Phil
Administrateur du site
Messages : 184
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

pgAdmin 3 ou pgAdmin 4 ?

Message par Phil » jeu. 30 août 2018 10:27

Merci à un développeur anonyme pour sa question :

Je n'aime pas pgAdmin 4, suis-je obligé d'upgrader ou est-ce que je peux continuer à utiliser pgAdmin 3 ?

Réponse :

pgAdmin 4 a été décrié à ses débuts, sans doute pour de bonnes raisons. Il a été amélioré mais entraîne malgré tout un changement dans les habitudes acquises avec pgAdmin 3. Je comprends donc les réticences.
pgAdmin 3 LTS (long term support) est encore maintenu par BigSQL, voir https://pgphil.ovh/windows_2012_postgresql_10_01.php
Cet effort individuel de BigSQL concerne essentiellement l'accès à de nouvelles versions de PostgreSQL mais ne doit pas masquer la réalité : c'est pgAdmin 4 qui est activement développé. Il est recommandé de s'habituer à cette version pour continuer à utiliser pgAdmin.
Si vraiment pgAdmin 4 ne convient pas, il existe d'autres excellents produits comme Dbeaver : https://pgphil.ovh/dbeaver_4_01.php
Cdlt. Phil - pgphil.ovh

Répondre