Support du traqueur

Les utilisateurs n'aiment ni interrompre leur travail ni regarder le sablier
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

Pour les utilisateurs ayant remonté une impossibilité de se servir du traqueur avec les versions 12 et 13 sous Debian, notamment, il s'agissait d'un problème lié à plpython. Le traqueur sélectionne à présent, si nécessaire, l'extension plpython disponible. Le problème est donc corrigé depuis la version 5.0.1.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 5.01.00 était la dernière version du traqueur compatible avec PostgreSQL 9.5. Cette version restera en ligne mais elle n'est plus maintenue.
Le traqueur en version 5.01.01 est compatible avec les versions PostgreSQL 9.6 à 14.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 6.00.01 était la dernière version du traqueur compatible avec PostgreSQL 10. Cette version restera en ligne mais elle n'est plus maintenue.
Le traqueur en version 6.00.02 est compatible avec les versions PostgreSQL 11 à 15.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

"La 6.0.2 est elle la dernière version compatible avec PostgreSQL 15"
Merci à Lucas pour ta question. Le traqueur >= 6.0 est ok avec PostgreSQL 15.
La 6.0.2 est notamment OK. J'ai enlevé pas mal de code spécifique PostgreSQL 10 dans cette version (15k sur les 120k, j'espère ne pas avoir trop coupé). Il est aussi possible d'utiliser la 6.1.1 ou la 6.1.2.
Il ne faut en revanche pas utiliser la 6.1.0, elle est buggée. J'avais une conversion erronée de text vers bytea en tentant d'éliminer les hachages en md5 pour compatibilité avec des systèmes FIPS ( https://en.wikipedia.org/wiki/Federal_I ... _Standards ), même si je n'utilisais en fait pas md5 pour la sécurité.
A+
Phil
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

Merci à Marc pour sa remontée de bug :
il y a une erreur dans traqueur.sh ligne 1121.
Il manque un poit-virgule
Bug introduit en 7.00.00 avec la fonctionnalité de calcul de la latence I/O depuis PostgreSQL 16 et +, corrigé en 7.00.01.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 7.00.01 était la dernière version du traqueur compatible avec PostgreSQL 11. Cette version restera en ligne mais elle n'est plus maintenue.
Le traqueur en version 7.00.02 est compatible avec les versions PostgreSQL 12 à 16.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 7.1.0 est disponible ce jour. Elle corrige le nommage d'une colonne de la table traqueur_times (colonne inutilisée dans les rapports texte). Elle ajoute par ailleurs la collecte et l'affichage d'informations sur la mémoire disponible et le swap pendant une période d'analyse, en mode interactif, en mode batch et dans les rapports, si l'option -p est utilisée.
Note : normalement traqueur_times devrait s'appeler traqueur_cpu_times mais ça ne sera éventuellement corrigé qu'en version >= 8.x pour compatibilité ascendante.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 7.1.1 est disponible ce jour. Elle corrige le filtrage des informations concernant la consommation mémoire et le swap (informations ajoutées en 7.1.0) dans les rapports produits avec l'option -r et -p. Avant le correctif, l'analyse était toujours faite sur l'ensemble des données, sans tenir compte de la période fournie.
Cdlt. Phil - pgphil.ovh
Phil
Administrateur du site
Messages : 288
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Support du traqueur

Message par Phil »

La version 7.1.2 est disponible ce jour. Elle corrige un bug présent depuis l'introduction du partitionnement avec l'option -j en version 1.2.0. Les partitions n'étaient pas "unlogged" même en utilisant -b U en mode batch, ce qui entraînait une journalisation non souhaitée lorsque le partitionnement était demandé. Passer les partitions en unlogged via -e U , en revanche, était OK.
Cdlt. Phil - pgphil.ovh
Répondre