Erreur en début de sauvegarde avec Barman 2.4 ('ascii' codec can't encode character)

Les utilisateurs n'aiment pas perdre de données
Répondre
Phil
Administrateur du site
Messages : 184
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Erreur en début de sauvegarde avec Barman 2.4 ('ascii' codec can't encode character)

Message par Phil » ven. 28 sept. 2018 16:56

Merci à Vincent pour sa question :


J'obtiens cette erreur en tentant de sauvegarder un cluster PostgreSQL fraîchement initialisé avec Barman 2.4 sous RHEL 7.4 (tout est en UTF8 sur le serveur) :

-bash-4.2$ barman backup portail_p_10
Starting backup using postgres method for server portail_p_10 in /var/lib/barman/portail_p_10/base/20180928T163333
Backup start at LSN: 0/4000300 (000000010000000000000004, 00000300)
Starting backup copy via pg_basebackup for 20180928T163333
ERROR: Backup failed copying files.
DETAILS: 'ascii' codec can't encode character u'\xe9' in position 17: ordinal not in range(128)

Comment faire pour s'en débarrasser ?


Réponse :
Ce n'est pas très académique mais cette solution suggérée par Евгений Афанасьев fonctionne.
Editer le fichier ????/barman/cli.py en ajoutant dans main()

Code : Tout sélectionner

reload(sys)
sys.setdefaultencoding('utf8')
Cela doit donner :

Code : Tout sélectionner

def main():
    try:
        reload(sys)
        sys.setdefaultencoding('utf8')
Attention, cette rustine est susceptible d'être écrasée lors d'une mise à jour de Barman...
Cdlt. Phil - pgphil.ovh

Phil
Administrateur du site
Messages : 184
Enregistré le : mar. 1 sept. 2015 00:38
Localisation : France
Contact :

Re: Erreur en début de sauvegarde avec Barman 2.4 ('ascii' codec can't encode character) -- bug corrigé en 2.5

Message par Phil » lun. 29 oct. 2018 10:47

Ce bug est corrigé sans nécessiter de bidouillage par Barman 2.5 sorti le 23 octobre 2018.
La bonne solution est donc à présent de mettre à jour Barman vers la version 2.5.
Cdlt. Phil - pgphil.ovh

Répondre